SouthLoop Group

Supporting the communITy

Mikrotik Dude Tools

The Dude by Mikrotik is an awesome program, not only for monitoring Mikrotik gear but also other SNMP and non-SNMP devices in a graphical format

NMS systems are great for indepth data and historical logging - but the graphical layout The Dude offers gives users a quick way to view the statuses of devices on your network.

 

In this article we will cover some of the tools you can create for use.

Note that the instructions here are for Windows computers - you can run The Dude in WINE or another emulator for Linux or Mac but for simplicity we will stick to Windows.

 

For starters we will create new Tools within the Tools menu from the left hand side tree of The Dude screen.

 

puTTy:

If you use SSH, telnet or Serial access - puTTy is a great tool that is lightweight but very functional.

Depending on how you download and/or install puTTY, you may need to modify the path name to fit.

Click on the Red + to create a new executable tool.

In the name section put: puTTY

in the Command section put:
"C:\Program Files\PuTTY\putty.exe" -ssh [Device.FirstAddress]

OR wherever the putty executable is (e.g. C:\Utils)

Go OK and that's it.

 

Winbox:

Winbox is the default access tool to Mikrotik's gear. Although some may find it clunky at first - there is method to the madness.
Download WinBox from Mikrotik's website and copy in this instance to C:\Utils (or where suits you the most).

As before, in the Name field put: WinBox

Command will be: 
C:\Utils\winbox64.exe [Device.FirstAddress] [Device.UserName] "[Device.Password]"

If you have a Mikrotik device in your Dude map set up correctly, this will use the IP, username & password to open WinBox ready to go.

 

Conclusion:

Now that the both above are done, you will see 2 new entries at the bottom of Tools> in the right-click menu for your devices:

Diafaan SMS from The Dude

This was done some time ago for someone but still works. It uses Diafaan SMS Server as the Web/SMPP Server.

There are other programs out there 

If you use "The Dude" and need SMS alerts when something goes astray, then this may help.

 Obviously below you need to set:

  • URL
  • username
  • password
  • to

According to your needs and Diafaan settings (which are hinted at lower down the page).

 
:local notificationtext "Service [Probe.Name] on [Device.Name] is now [Service.Status]"
:local notificationtextEncoded

:for i from=0 to=([:len $notificationtext] - 1) do={ 
  :local char [:pick $notificationtext $i]
  :if ($char = " ") do={
    :set $char "%20"
  }
  :set notificationtextEncoded ($notificationtextEncoded . $char)
}
:put $notificationtextEncoded

:local url "http://your.serveraddress.here:9710/http"
:local username user
:local password pass
# :local from dude
#
#
# First Name Last Name
 :local to "+xxxxxxxxxx"
#
/tool fetch url="$url/send-message\?username=$username&password=$password&to=$to&message-type=sms.automatic&message=$notificationtextEncoded" keep-result=no
# And test it via pressing Test button.


#Service [Probe.Name] on [Device.Name] is now [Service.Status] ([Service.ProblemDescription])

To add this entry look under Notifications on the left hand side of The Dude panel.

Note that SMS2 is via SMTP and will depend on your mailserver to sort.

 

 

Within Diafaan:

You will need to first create a Connector within Diafaan SMS Server to do this.

You must click on Test to continue to the final steps - this checks that the service starts properly and that the TCP port is unused by anything else.

Select Web Connector on the left hand side and choose Edit connector properties on the right of the screen.

Ensure your that Enable HTTP API is on and set as above.

You will then need to log into the local web server with your Diafaan user credentials and create the user you need to send SMS' from.

 

Remember to Test inside The Dude before thinking it's all go.